Live view not working

Hi mates,
I have upgraded version 2 to 3 after reading about substream for live view.
Well, live view does not work anymore. I can see only white pages.
Tried both with normal stream than substream (working in VLC).
Purged the “upgrade”, started from scratch. Same situation.
Rolled back to V2. Waiting forward for this release, thanks!

1 Like

I ran into the same issue with the live stream on v3 in the web interface, I just hadn’t reported it as I was still trying to get the ipcam viewer to work with v3 (I don’t think it currently does).

1 Like

I mean, some programmer here? I would like to partecipate to beta testing, but please a solution. Thanks

Can you provide some logs? And stream parameters? Is audio enabled on streams? Does it work in Bluecherry Client?

Hi Anton,
with the client in the live view section after some seconds of connecting retries I have an error:

image

This is the setting of a cam (I use five, same brand)

With substream activated I have these logs:

Apr 24 09:18:27 bc-server[4960]: I(1/Nord): Stream started: Video: h264 (Main), yuv420p(progressive), 1920x1080, 1/90000(s) 1/30©
Apr 24 09:18:28 bc-server[4960]: I(1/Nord): Substream started: Video: h264 (Main), yuv420p(progressive), 768x432, 1/90000(s) 1/20©
.
.
.
.
Apr 24 09:20:21 bc-server[4960]: E(1/Nord): Read error from liveview substream: End of file

Trying to disable substream and use only main stream does not change the situation:

Apr 24 09:24:31 bc-server[4960]: E(1/Nord): Read error from stream: End of file

Live view does not work both from client and web page.
Audio is not enabled on streams…

Thanks a lot,
Andrea

You have invalid values in “Path to RTSP” and “Substream Path”, according to screenshot you put full RTSP path there, but there should be only “/Streaming/Channels/101” and “/Streaming/Channel/102” respectively. Full RTSP path components (IP, username, password, port, path) are split into separate fields there.

Strange… The values are migrated from ver 2.8. It is an upgrade from this version (where they work) . I will check it and let you know.
Thanks!

Changed settings as suggested, same errors and live view still not working. Thanks

It looks very strange, it should not work this way in v2.8 too. Can you show the current settings screenshot again? With fixed paths?

Sure, thanks.
A small precisation: if I use client and move the mouse arrow over the column “event” I can see a small thumbnail of the camera:

Here is the setting. I have tried TCP and UDP with the same result:

So? What may I try now?

Turn off the “Use Substream for Live View”. I had the substeams working great for a while, then suddenly stopped working for live view. The thumbnail you’re seeing is from the actual recording which is coming from your main stream setting. If you turn off using the substeam, you’ll be able to view the main stream in the BC app.

As I wrote before, it does not work both with primary and substream…

Are you talking in the application or the website? The web page definitely is broken for live view on 3.0, the application i’ve not had any problems with the primary stream, but mixed success with substream.

I am talking about live view. I am not able to see any stream both in app and the web interface.

Ok, my bad - from the screen shot showing the events to me it looked like the app interface and not the web interface. Yeah, AFAIK the live view on 3.0 is completely borked for the web interface.

1 Like

Are there any error messages in bluecherry server logs?

No errors on server logs :man_shrugging:

Anyone? heretocompileatleast20chars

So, why have I to buy this software if no one helps the beta testers???