Web management not logging in, Just sits and says loading


I week or two ago I found out I am not able to web into DVR. The web page / interface just sits at the Loading …
I am running Ubuntu 20.04.5 LTS
I use to have no issues and then I think an Ubuntu update must have clobbered something???
I can log into the GUI of the DVR Linux desktop and run the Linux client program and it reads the cameras and shows they are recording. I have all cameras set to continuous, so not an issue or real concern to have to use the web side. But if I need to tweak things and check some things I am not able to log in. I glanced over a number of posts and did not see anything jump out at me. (By the way, I really like the Linux client and Windows client as well, thanks for the hard work on developing them and having them available and I hope they will stay in production long down the road)

Anything I can try to do or??

On a side note:
Anyone running DVR on Ubuntu 22.04? I was thinking of spinning up a VM of that and putting the DVR on to see if / how it runs. Stay on 20.04 or consider going to 22.04? Not sure if just getting it flipped to the current Ubuntu if that would help or make a difference for the next DVR updates down the road.


You can try this package: http://lizard.bluecherry.net/~curt/tmp/focal/bluecherry_3.1.0-rc6_amd64.deb

wget http://lizard.bluecherry.net/~curt/tmp/focal/bluecherry_3.1.0-rc6_amd64.deb ; sudo dpkg -i install bluecherry_3.1.0-rc6_amd64.deb

22.04 is not currently supported, but will be soon.

I checked it and the system is running that. I thought when DVR installed it hooked into APT so when I run the apt-get update and -upgrade it will also go out and look for and install any new DVR update as well. I ran the command apt list --installed I do have it.

binutils/focal-updates,focal-security,now 2.34-6ubuntu1.3 amd64 [installed,automatic]
bluecherry-client/focal,now 1:2.2.9-1 amd64 [installed]
bluecherry/focal,now 3:3.1.0-rc6 amd64 [installed]
bluez-cups/focal-updates,focal-security,now 5.53-0ubuntu3.6 amd64 [installed,automatic]

I even ran apt update and then apt upgrade since it had updates. Then I rebooted, and tried to web in It just sits with the green bar with loading…

Any ideas?

Use the package I sent you, it is a slightly newer version then rc6.