Substream view with client app on 3.0.3 server

Hi all,
I’m attempting to use the camera substreams to conserve bandwidth on the monitoring station. I’m attempting to use the substream path. The mainstream path works fine, but there seems to be a problem with accessing the substream.

Here’s the main stream path: /cam/realmonitor?channel=1&subtype=0&unicast=true&proto=Onvif

Here’s the substream path: /cam/realmonitor?channel=1&subtype=1&unicast=true&proto=Onvif

RTSP Port: 554
IP: 172.16.10.87
substream setting: 640x480, H.264, CBR 512Kbps

On my BC client I’m seeing:
Error
Open Error: Server returned 404 not found

I took the substream path and plugged it into VLC and after entering the username and password for the camera, the substream came up as it should. Any thoughts why the substream would be visible with the full path ( rtsp://172.16.10.87:554/cam/realmonitor?channel=1&subtype=1&unicast=true&proto=Onvif ) in VLC but BlueCherry can’t access it?

If I turn off substream viewing, the BC client shows the main stream without a problem.

That is strange. Do you have Livestream reencoding turned on for that camera in the Bluecherry settings?

I just tested sub streaming with 3.0.3 on a Dahua camera. The Dahua settings are:

image

Sep 23 19:33:15 bc-stable bc-server[28907]: I(21/Dahua): Substream started: Video: hevc (Main), yuv420p(tv), 704x480, 1/90000(s) 1/90000©

I didn’t think H.265 was supported yet for the client? No, I don’t have livestream re-encoding turned on.

I tried with both H.264 and H.265, both worked.

What is the camera model you are using?

Amcrest and HikVision. The H.264 worked, then stopped working for no apparent reason after I had several cameras set to using the substream. I swapped to H.265 and it seems to be working now without issues.

Can we use H.265 for the main stream for the recording at this point as well? (thinking it might expand my storage length a bit)

You can certainly try H.265, it may be hit and miss. I’ve noticed before on Amcrest the camera doing weird things where it would drop 50% of packets and a power cycle was the only way to fix it. If you notice your Amcrest doing “weird” things maybe a power cycle can fix it.

Thanks

Please check that recordings in H.265 are playable, there were some issues with that, so now H.265 is recommended for liveview substream only.