RTSP Buffer Adjustment

Is there a way to adjust the rtsp buffer for a stream? I’m getting half images that I’ve known to adjust in other images with a buffer size field. This is a fresh install using the link on the download page on Ubuntu 22. If I put the same stream URL in the substream path, it shows up completely. Maybe this belongs in the v3 page?

bc-server 3.1.0 (toolchain 11.3.0) v2.7.6-733-g6e6e1d92 heads/master

What buffer size would you normally use for this same camera?

Added here - Add buffer size adjustment for RTSP streams · Issue #593 · bluecherrydvr/bluecherry-apps · GitHub

Hi @travis ,

Can you please give a little bit more info about the stream?

  1. What is the original RTSP stream link you are trying to record or re-stream using Bluecherry?
  2. What is the link you are trying to play and the images are half? Does Bluecherry generate this stream or it is generated by the camera?
  3. Can you also try to play the problematic RTSP stream using VLC and/or ffplay and check if its playable correctly with these players?


Currently, this stream is proxied by a ubiquiti unifi video server (autogen url) and sent to bluecherry for testing. I will try direct from some dahua 5MP cameras this afternoon. This was a common issue with several other NVRs on the dahua cameras that I have tried and they have the packet buffer size adjustment for that. On other NVRs, the Dahuas I have are set to a buffer of 512k.

This images are recorded and shown in the live view as shown above. This is in the windows client and the browser. The exception is if I stick the same URL in as a substream. Then I see the full picture. I’m assuming thats due to the way its processed, but I’m no dev.

The stream works fine in VLC.
Here is the info from VLC:

So, I did another fresh install, but on Ubuntu 20.04 (diff physical server) instead of 22.04 Used the same link to do the install and it appears to be working. I see a full picture. I also see a full picture of the dahua cameras.
Edit 2
I tried doing another install with Ubuntu 20.04 on the same equipment as I installed 22.04, but the install script continues to error out after the config prompts. Still looking into it.
“dpkg: error processing package bluecherry (–configure):
installed bluecherry package post-installation script subprocess returned error exit status 1”

Now its magically working on another fresh install of 22.04…so im not sure entirely whats going on…I’m going to continue to play with this over the weekend and I will let you know if I see any more issues with the smearing/buffer issues.

Okay, I’m going to give you a new package to test for 22.04. This raises the buffer from 128 to 512k. Only install this package if you start seeing the buffer issues again. Give me a little bit of time to build it


Could we get access to a RTSP URL or two so we can remotely work on this issue? Opening a direct port to the camera (outbound port doesn’t matter as long as it is forwarded to port 554 on the camera)

Yes, I will work on that over the weekend and send you a message. Thanks