No recording available through Client


I’m trying to figure out if this is a server, or client issue. We are currently in the trial period, and have decided to go ahead and license BCDVR. However, 2 linux clients, 3 mac clients cannot view any recordings in Server → Browse Events. It’s just blank in the list/Timeline sections, and “Everything” is checked. I’ve even tried individual cameras, still blank. However, in Chrome recordings are available.

Server is Debian Bullseye running server version 3.
Clients are all running 2.2.9

Anyone experiencing the same issue, and a possible fix?




Can you try running ‘sudo service bluecherry restart’ on the command line and trying again? Past video files are served up via nginx for both the client and web interface on port 7001, so it is strange it works for the web interface and not the client.

Hi Curtis,

Due to out of memory errors (Only 12GB installed w/15 cameras, 32GB to be installed soon) I’ve had a cronjob restarting the service every 8 hours, but I went ahead and did the restart anyways. Still no recordings in the client.

I doubt this is related, but I should mention it. I did edit the nginx config, and removed the snakeoil.conf in place for our own config that specifies our SSL cert/key. It’s listening on port 7001, and serving up our certificate as expected. I never tried the clients prior to that change.

Btw. You’ve been working with my boss on the client download issues through chat the past couple days, and we are VERY impressed with you & Bluecherry.



I just deleted my reply as I thought the provided cert fixed it, but the recording went away.

Very strange. If you try to download the mp4 files from the web interface?

Yes, I can download the mp4 from the web interface.

Can you setup teamviewer so I can connect and look at this? You can message me the details.

Unfortunately I cannot at the moment, the way our server is firewalled off from the world won’t allow it unless it’s through our vpn.