Live view over port 7002 impossible for higher bitrates

Good morning

Configured now a E1 Zoom and E1 Pro for bluecherry 3.0.4…

I can watch the live stream via port 7002 okay for the E1 Pro, which is a 4MBits/sec 2560x1440 stream…

but it is not possible for watching the stream from the E1 Zoom, which comes also as a 4MBits/sec 2560x1920.
See only artifacts…but on the bluecherry machine the CPU load is low with around 12%…

Is there a limit of the bandwidth/resolution I can use with bluecherry???

thanks in advance
richard

Okay…something to do with the 3.01. to 3.04 update…

Last night recordings look fine:

But now it is just rubbish:

1 Like

Can you confirm you are using 3.0.4 and not 3.0.3?

dpkg -l bluecherry

Does restarting the server help? ‘sudo service bluecherry restart’

There were no changes recently that would cause this corruption.

Yes…the admin page says 3.0.4 after upgrading with apt update on Debian 10.7…

Tried again with a restart…recording was fine now…have to check with other cameras doing 2560x1920…

Still the error loading resource error persist when trying to play back…

1 Like

Are the cameras H.264 or H.265? If they are H.264 make sure they are H.264 and not some strange non-standard H.264.

Can I get remote access to the server?

They are all h264/aac cameras…can import the mkv clips in kdenlive…

One thing I’ve discovered with my models that when playing back a recording that the clip stops around every second for a short moment…

Probably framerste is not recognized correctly and replaced with a default one?

VLC shows for all thre cameras 29.97 fps though one is set to 30fps@8mbps and the other two are 20fps@4mbps.

Have to check tomorrow if I can install bluecherry on my media server which has it’s own public v4/v6 address…though it would require that you’re also connect from a static v4/v6 address…

cheers
richard

1 Like

i have the same problem with my other reolink cameras. i have confirmed through the reolink app that the camera broadcasts are working fine and that it only looks like that when i view them through the bluecherry app. restarting the cameras that are not working correctly usually solves the problem. when my server needs a reboot sometimes as many as 1/4 of the cameras come up, after reconnecting, with this problem, until those cameras are rebooted or the server is.

i thought it had something to do with reconnecting the camera in bluecherry so i tried to disable and then enable the device from within the server’s web interface, but that never worked.

@ironsmith @davorin are you both using sub streaming in v3? Can you disable substreaming?

How about audio? Is audio enabled? If so, does disabling audio help?

i have not tried audio ever. the onvif sets up a substream but i don’t understand how it is used. i could remove the substreams to troubleshoot the next time the problem occurs.

Evening :wink:

Waited for my NUC i7 to arrive today…the other test system was just a dual core, dual thread system…

Now just installed 3.0.4 on Ubuntu this time…
with just one RLC-520 atm at 2048x1536 at 25fps…

What about using RTMP?

Not sure if the media port 9000 is still scrambled with the “Charlie” passphrase…but Reolink apps and NVRs seem to use port 9000 only…

BTW: What is the substream used for? Is only the substream used for motion detection if present?

cheers
richard

Interesting

Ubuntu seems to support intel gpu better…have a live view :wink:

Okay…this is what I see when I enable audio afterwards on a camera:

Dec 17 14:01:07 zm bc-server[106830]: I(4/Office): Setting up device
Dec 17 14:01:09 zm bc-server[106830]: I(4/Office): Stream started: Video: h264 (High), yuv420p(progressive), 2560x1920, 1/90000(s) 1/180000©; Audio: aac (LC), 16000 Hz, mono, fltp
Dec 17 14:01:09 zm bc-server[106830]: I(4/Office): Switching to new recording schedule ‘continuous’
Dec 17 14:01:10 zm bc-server[106830]: I(4/Office): Substream started: Video: h264 (High), yuv420p(progressive), 640x480, 1/90000(s) 1/180000©
Dec 17 14:01:10 zm bc-server[106830]: E(4/Office): Initializing muxer for RTP streaming failed
Dec 17 14:01:10 zm bc-server[106830]: E(4/Office): bc_streaming_setup() failed: Invalid argument
Dec 17 14:01:10 zm bc-server[106830]: E(4/Office): Unable to setup live broadcast from substream

And soon afterwards when disabling audio:

loads of:

Dec 17 14:01:58 zm bc-server[106830]: I(4/Office): Substream started: Video: h264 (High), yuv420p(progressive), 640x480, 1/90000(s) 1/180000©
Dec 17 14:02:33 zm bc-server[106830]: E(4/Office): Read error from stream: End of file
Dec 17 14:02:45 zm bc-server[106830]: I(4/Office): Stream started: Video: h264 (High), yuv420p(progressive), 2560x1920, 1/90000(s) 1/180000©
Dec 17 14:02:50 zm bc-server[106830]: I(4/Office): Substream started: Video: h264 (High), yuv420p(progressive), 640x480, 1/90000(s) 1/180000©
Dec 17 14:04:06 zm bc-server[106830]: E(4/Office): Read error from stream: End of file

By far in any way usable for me…

Almost bought a license last night…but waited for the new RLC-520s to arrive to test more than one camera with bluecherry…

BTW:

Why are those settings missing when first setting up a new camera???

  • Enable audio
  • Enable sub stream for live view
  • Enable camera debugging

cheers
richard

When I just added the first RLC-520 with 2560x1920 at 25fps I only saw this in the logs for 3 hours:

Dec 17 10:51:46 zm bc-server[106830]: I(3/Hobby): Setting up device
Dec 17 10:51:49 zm bc-server[106830]: I(3/Hobby): Stream started: Video: h264 (High), yuv420p(progressive), 2560x1920, 1/90000(s) 1/180000©
Dec 17 10:51:49 zm bc-server[106830]: I(3/Hobby): Switching to new recording schedule ‘continuous’
Dec 17 10:53:22 zm bc-server[106830]: I(3/Hobby): Applying configuration changes
Dec 17 10:53:23 zm bc-server[106830]: I(3/Hobby): Device stopped: configuration changed
Dec 17 10:53:30 zm bc-server[106830]: I(3/Hobby): Setting up device
Dec 17 10:53:34 zm bc-server[106830]: I(3/Hobby): Stream started: Video: h264 (High), yuv420p(progressive), 2560x1920, 1/90000(s) 1/180000©; Audio: aac (LC), 16000 Hz, mono, fltp
Dec 17 10:53:34 zm bc-server[106830]: I(3/Hobby): Switching to new recording schedule ‘continuous’

Recording was fine and CPU usage very low:

Okay…when I remove the “use sub stream for live view” then it goes back to normal for both cameras…

The peak above 25MBits/secs was when disabling audio for the second camera…
so bluecherry used 20MBits/sec for a single RTSP stream which was set to 6MBits/sec, verified with VLC btw…

So wonder why bluecherry is unable to record anymore when I just enable “use sub stream for live view”, although didn’t use live view today at all…

And no clue what this means:

Dec 17 14:24:51 zm bc-server[136940]: E(3/Hobby): Initializing muxer for RTP streaming failed
Dec 17 14:24:51 zm bc-server[136940]: E(3/Hobby): bc_streaming_setup() failed: Invalid argument

We are just fishing in cloudy seas here…

Not sure if this will be better when buying a commercial or business license…

And next problem

When setting up re-encoding for a camera Ithe log file is flooded with:

Dec 17 15:44:13 zm bc-server[149956]: E(5/Network): Failed to initialize scaler instance for reencoding
Dec 17 15:44:13 zm bc-server[149956]: E(5/Network): failed to init scaler: Input/output error
Dec 17 15:44:13 zm bc-server[149956]: E(5/Network): Failed to initialize scaler instance for reencoding
Dec 17 15:44:13 zm bc-server[149956]: E(5/Network): failed to init scaler: Input/output error
Dec 17 15:44:13 zm bc-server[149956]: E(5/Network): Failed to initialize scaler instance for reencoding
Dec 17 15:44:13 zm bc-server[149956]: E(5/Network): failed to init scaler: Input/output error
Dec 17 15:44:13 zm bc-server[149956]: E(5/Network): Failed to initialize scaler instance for reencoding
Dec 17 15:44:13 zm bc-server[149956]: E(5/Network): failed to init scaler: Input/output error
Dec 17 15:44:13 zm bc-server[149956]: E(5/Network): Failed to initialize scaler instance for reencoding
Dec 17 15:44:14 zm bc-server[149956]: E(5/Network): failed to init scaler: Input/output error
Dec 17 15:44:14 zm bc-server[149956]: E(5/Network): Failed to initialize scaler instance for reencoding
Dec 17 15:44:14 zm bc-server[149956]: E(5/Network): failed to init scaler: Input/output error
Dec 17 15:44:14 zm bc-server[149956]: E(5/Network): Failed to initialize scaler instance for reencoding
Dec 17 15:44:14 zm bc-server[149956]: E(5/Network): failed to init scaler: Input/output error
Dec 17 15:44:14 zm bc-server[149956]: E(5/Network): Failed to initialize scaler instance for reencoding
Dec 17 15:44:14 zm bc-server[149956]: E(5/Network): failed to init scaler: Input/output error
Dec 17 15:44:14 zm bc-server[149956]: E(5/Network): Failed to initialize scaler instance for reencoding
Dec 17 15:44:14 zm bc-server[149956]: E(5/Network): failed to init scaler: Input/output error
Dec 17 15:44:14 zm bc-server[149956]: E(5/Network): Failed to initialize scaler instance for reencoding
Dec 17 15:44:14 zm bc-server[149956]: E(5/Network): failed to init scaler: Input/output error
Dec 17 15:44:14 zm bc-server[149956]: E(5/Network): Failed to initialize scaler instance for reencoding

And another very serious bug…

In the cacti graph I enabled one camera by one…(totally 3 RLC-520)…

After that I did a “systemctl restart bluecherry”…and suddenly the bandwidth usage is higher…also with larger recording files which all are now corrupted!!!