Linux RTSP Camera Addresses

Hi All,

I am a newbie to Bluecherry but the software appeals. So I am trying to rejig my system to work with this software.

First up I have to say that my household is exclusively Linux, main machines are Ubuntu 20.04.

My current security camera system has 4 x Hikvision (HiLook) IPC-T250H 5MP cameras connected to a Hikvision (HiLook) NVR-100MH-D/P (8 ports).

I have loaded the Bluecherry Server application on an old Asus 4GB system using the Bluecherry script. This seemed to go well and I then loaded the Client onto the same machine.

The client connects to the server with no errors and is on the same WiFi network as the NVR. However, I am not able to connect to the cameras using using rtsp (or at least I couldn’t see any actual vision from the cameras on the Server or Client).

So I decided to remove the Hikvision NVR completely (which, for me, is more preferrable anyway). To test this I put in a PoE switch and plugged one camera directly into it. Using Linux netdiscover from the Asus machine I was able to determine the cameras IP address. But for some reason I can’t seem to get the right syntax for the rtsp connection to work on my Bluecherry Server / Client setup. The camera(s) have an ‘admin’ user and currently no password (I can see that through the existing NVR software).

I understand that I can use wireshark to obtain the rtsp address, but for this to work the camera(s) must be operating and transmitting data. Only this is a Catch 22 situation for me because I don’t have the correct rtsp details to request a transmission.

I would appreciate if someone could provide some guidance here on how to identify the correct rtsp details on Linux.

I replied on the slack channel, which clearly doesn’t flow through to the forums.

Here is a link which details the stream path:

Your rtsp port is configured within each camera. Mine were 554 (but I am using Tapo cameras). Check the webgui on your cameras.

Not sure if having an account but no password causes any issues but you can test than in VLC (Google vnc rtsp for the url format if you aren’t aware). If it works there it SHOULD work in bluecherry.

Hi ProwerfreakOZ,

Thank you very much for your reply - appreciated. I have checked with the site and it appears that my rtsp string is correct. So I will have to look elsewhere. I’m thinking that it’s a IP conflict or a network mask issue. I will check both of these out as soon as I’m able.


Hi Kel,

I had a few issues with some older ACTi cameras. I’m not familiar with the Hikvisions, but I had to enable RTSP authentication and disable B2 Frames. Enabling authentication implies a password, so adding a password, or a user/password combo if you don’t want to password your admin account, might be required. I couldn’t connect using open RTSP. Also, I tested my rtsp connection using VLC. The ACTi cameras have a non-standard RTSP port (7070), so I did have to change the port in the bluecherry properties for the cameras. And one final thing, all of our other (newer) ACTi cameras use “/stream1” as the path to the primary rtsp stream, but the older ones used “/track1”. When I add cameras I always just select “Generic” and enter the parameters myself. I’m currently running BlueCherry v3.0.4 on Ubuntu 20.04 LTS (as Hyper-V VMs). I upgraded to 3.1.x (or whatever currently installs from the repo with apt), but I had issues so reverted to the older version which is rock solid for me. I put a hold on it so apt skips upgrading until the bugs are worked out. Also had issues with the 2.2.9 client (for Windows), so I’m using v2.2.6.


Hi Klorentzen,

Thanks for taking the time to respond. I think your Linux skills are more advanced than mine. However I have solved my rtsp syntax issue (at least on the single camera I have managed to take off my NVR. The string I needed to use turned out to be rtsp://Admin:[Verification Code]@192.168.x.xx:554/Streaming/Channels/101/. I think the second channel is 102. This gave me access to the camera on VLC.

A big note here: This was through trail and error but and it seems that the Verification Code is not the normal administrator password for accessing your NVR. It is instead the password that is shown under the Hikvision (HiLook) NVRs Configuration, Network, Platform Access (tab) as the ‘Verification Code’. From my reading on this, the Verification Code is the encryption key required to understand the stream, NOT the access code of any admin or user. Once I put the above into VLC and pressed stream, VLC then displayed a login and password dialog box. This is where the actual admin name & password is taken. Hopefully I can work out how to put both into the rtsp string. If you have any advice on that I would appreciate it? I did once see ‘auth=’ in a string so perhaps that’s where I can add this in (more research needed).

All this took some time so I haven’t yet had time to successfully get this working with Bluecherry - but I note your comments above re versions and adding cameras as generic.

Thanks again for responding.