IPCam Viewer connection issue

Hi all,

I’m having some issues trying to get ipcamviewer to communicate with BC. I’m testing with the lite viewer - I’ve added the unit as type Bluecherry DVR, IP of the test server, port 7001, SSL turned on, user admin and base password (bluecherry - since this is an inhouse test that isn’t externally reachable, no big deal); the phone is on the same VLAN as the server, and trying to reach Channel 4 (there is a camera with an ID of 4) and I get a “Error could not retrieve data” on IPCam Viewer.

In the apache logs for blue cherry, I’m seeing this: - - [10/Apr/2020:09:53:31 -0500] “GET /xxxxxxxx.html HTTP/1.0” 200 1247 “-” “-” - admin [10/Apr/2020:09:53:32 -0500] “GET /media/mjpeg.php?multipart=true&id=4 HTTP/1.0” 200 1608 “” “Mozilla/5.0 (iPhone; CPU iPhone OS 7_0 like Mac OS X) AppleWebKit/537.51.1 (KHTML, like Gecko) Version/7.0 Mobile/11A465 Safari/9537.53”

I also tried a manual pull of a single frame with:


and all I got back was a blank white page…

I know that ipcamviewer is a separate product from someone else, I was just hoping that someone might have a clue what I must have done wrong :smiley:

Are you sure the port is 7001? I remember it was 7002

I’m using this also, and no problems at all. I have it as Camera brand Bluecherry, camera model DVR. Host name is just the host name, port 7001, Server push (MJPEG), use HTTPS, and my credentials. I do have under the main app security settings “Untrusted SSL certificates” or it wouldn’t connect after it had defaulted my ssl key after one of the upgrades.

Where do you see that level of settings? In the free version of ipcam viewer for the camera settings I see:
Name (general name, not important)
Type - Bluecherry DVR
IP/Host - set to IP address of internal test server
HTTPs Port - 7001, ssl enabled
User - admin
Password - set correctly
channel - 4 (known current camera ID)

I don’t see anywhere in the main app settings untrusted ssl certificates. Are you on Android or iOS? Also are you using the free or paid version of ipcam viewer?

Yes, it’s asking for the https port not the rtsp port

Actually I apologize… I had issues with IPCam Viewer now that I think about it and switched to tinyCam at some point, sorry about that :frowning: FWIW it’s been solid for me.

EDIT: They were so similar, I had honestly forgotten I had switched awhile back, sorry for the confusion.

TinyCam, blue shield logo with what looks like aperture blades on it? I just tried to run it and comes up with a panel for “wificam” and the + doesn’t give an option to manually specify ip/port/etc. I’m wondering if I downloaded the wrong package?

well, just found the home page for tinycam, looks like its android only - I’m on iOS :frowning:

I just Googled, looks like Android OS only, sorry to doubly let you down :frowning: