IP camera discovery

Good morning

Could just upgrade to 3.04 with apt upgrade on my Debian 10.7 test system…

Quick question…

What types of cameras should “detect ip cameras” actually detect?

At least it doesn’t see any of my 3 Reolink ONVIF cameras (E1 Pro, E1 Zoom and RLC_520) which can be detected easily via any IP cam software on my iPad/iPhone…

thanks for clarification

we have almost completely moved to reolink cameras (about 22 of them in total) so i understand your problem. i belieive the reason for this is that bluecherry uses the default port 80 for onvif detection where reolink cameras use port 8000 for onvif.

Well that would explain it…though many Reolink cameras use http port for the web page…the E1 Zoom even requires flash plugin with latest firmware :wink:

Which Reolink models do you use?

I’m currently testing:

  • E1 Pro
  • E1 Zoom
  • RLC-520

Although bluecherry shows low CPU usage in mostly all recordings the clips stops for a short time every second…

Not sure if it has to do as VLC shows always a frame rate of 29.97…

we use mostly rlc-410 with some rlc-511 z and rlc-423 ptz.

the slow-fast repeat sometimes has something to do with a mismatch of framerates. try to change your cameras encoding framerate to match as closely as you can (or exceed it) the framerate that is shown in the bluecherry client. if it is still happening sometimes a simple reboot of the camera will allow bluecherry to reconnect to the camera and resolve the problem. it happens sometimes to us but once resolved it does well for weeks and sometimes months before any additional troubleshooting might be needed.

i just experienced the clip stopping for a short time every second. i tried adjusting everything from framerate to bitrate. i rebooted the camera, i upgraded the firmware, i removed substreams, nothing worked. it will likely behave if i reboot the server but i hesitate to reboot the server because of reconnection issues with the cameras where the whole thing looks like one big smear.

Okay, good to know. I am having the same issue. Maybe in time, as part of the Find Cameras function, maybe have it show the progress as it scans the I.P. range, like just an I.P. that increments the last .xxx so at least you can see that it is actually working and scanning for cameras. I will have to put a suggestion in the right spot. Okay so looks like manually add generic cameras and configues the RTSP stream settings and credentials.