Installation fails every time

I have tried to install Bluecherry on Ubuntu 18.04 and 20.04. In all cases the installation fails. I can remove Bluecherry but the purge fails. The first indication of a problem is during the install is towards the end. This is the error.
error access denied for user ‘bluecherry’@‘localhost’

I just tested 3.0.6 (latest v3) on a clean install of 18.04 and it installed fine. Are you using v3? Can you attach the install logs and remove the password that is listed in the log output?

I’ll post soon. I am using the unstable track.
sudo bash -c “$(curl -s”

While I wait for the system to update, are there any conditions that need to be met such as a static IP address, root password, etc?

Nope, all of those can be set during install or afterwards.

Where is the log file?

Copy and paste the results of the installation (or failure in your case)…it should be several pages.

Bluecherry log.txt (37.1 KB)

In this case the database ‘bluecherryhome’ already exists.

Purge everything:

sudo apt-get remove --purge bluecherry

Drop the database:

mysql -u root -pPASSWORD -e "DROP DATABASE IF EXISTS database"

Then try to install again. This time just use the defaults, only setup the mysql passwords (don’t mess with the host settings).

The MySQL command doesn’t work. All my previous attempts used the default settings. I tried something different this time. I’ll start again tomorrow with a fresh install it 18.04 server again.

I tested today with 20.04. I think the problem is the misunderstanding of the database host field. It needs to be the mysql server (use localhost).