How does one get in on beta?

im currently using shinobi, just record a cam out apt window, cam in garage and cam on apt door. the box ive dubbed floor serve is a gigabyte md70 with e5 2660 v3 and at the moment 32gb registered ecc ddr4 in two dims. clearlinux is host os and kvm is rocking web server, router for /29 static block and nated private subnet. then shinobi is hanging out on a ubuntu 16.xx install, i can rock basicly any distro needed with this setup.
separate intel x540 (mobo has one but its hung off the unpopulated socket). sriov is on and im passing vfs to guests as needed. is hosted on this box via 80/40 centurylack pppoe/modem in bridge to opnsense.

also ill probably post this elsewhere but from the little i gather v3 is supposed to add to what the gpu can be used for on the server?

is it possible to transcode or encode on an Nvidia card? ive got a 1050ti passed through to ubuntu 16;xx for shinobi at the moment. if not an easy check box sorta option is there any ability in the underlying software? like is it a matter of compiling ffmpg or installing what ever is used behind the scenes but possible?

sudo bash -c “$(wget -O -`”

will install the latest beta
settings -> General settings --> Performance/connectivity --> VAAPI device
than pick the nvidia card

i can not tell you if how well its works , due to i dont have access to a nvidia card

thanks! ill check it out and report back!

something was malformed above but my eyes are teribad. 90% progress once i just typed the dl.url part the coppied link source and did a sudo wget… ohh a wild purplish background install dialoge has appeared…

take 2… "configuring bluecherry, please enter mysqladmin users name. well … this was a fresh ubuntu server install not sure its on there at all did get a lot of terminal whizzing by a moment ago… first issue here is its unclear other than context if im setting something on an about to be created db or if i was supposed to have grabbed mariadb, ill figure it out either way in a moment

its odd, i started fresh ubuntu 18.04 maybe my error was in doing the apt update apt upgrade or further back in leting the iso in vm hit server for updated install? either way i can see that im having dependency and version issues. i think i got maria removed and /etc/mysql/ has config options but i saw something about back track/back up change history log…wrong version in journalctl so i think something packagewise/dependency/version of mysql is off still. I cant run mysql secure install due to not finding the socket file (rather it not seeing it cause its not there…i looked on my own as well) ill look up that down grade script shortly. i have to wonder how much of the pita i have been experiancing with debian based distros is due to the founders passing and how much is influnced by ms’s input (ive read a few things) Ive managed to do most of what ive needed for the past year with this kvm box on floor and get cent on a vps for a client into what at the time was an odd config (centos 7 lxd containers and ipvlan passed through before that support was auto config/built into lxd)(containers because i went litespeed on newly released free but enterprise license, stipulation was wont start if over 2 gigs of ram… ok well container and put db in another or on host and a lot of things from backup to test enviroments also easier (after figuring out the networking lol) before that though there was like a 6 year gap in linux… i just remember it being less fractionated and things like package managers working better back then but maybe im just romancing the past. any input appreciated. …

oh, forgot, maybe relevant, I also got the ubuntu driver manager running before attempting the install. (nvidia 1050ti passed to the kvm guest) not sure if it plays with package versions in dependencies or messes with selected and or that future apt installs grab the wrong one (not entirely sure on terms for all these concepts but somewhat/think i get the concepts/places errors may creep… not sure if that or letting the manager load the blob/closed nvidia driver is relevant but as long as im posting it seemed worthy to include

i havent parsed the install script (in its entirety) with my eyes but did end up with it open for long enough to note that ubuntu 18.04 is intended/supported for the unstable script /slowly trying to peace together more on my own

fingers crossed, i found a doc from 2.8 mentioning mariadb from apt is an issue. deleted the repo from sources dir added the official orical repo, not sure if i should have done 5.8(i think) or the 8 version but I then noticed that earlier in the install I got a prompt asking to actually set root password. then back to cl and scroll until again pinkish config and wanting root then set up user… it errored out in the end and i notice the output is lacking a space between flags/switches/config options and the value but not sure if thats whats actually being entered by the script or just what i see post fail. on the plus side the secure install script actually sees the SQL server (tried it after bc script errored)

i just tried manual copy of bc conf template input the db info and systemctl restart… status now says its running /started free of error

derp… could not connect to db (but im reading that with https://local ip:7001 via chrome, so… progress)
mysql error log showing access denied for the user, guess ill either hit cl or install the phpmyadmin and track down how much of the table and related was or wasnt entered

it has the db (i changed the name and the use command worked but list is producing nota) tempted to add user via cl and see if bc tries to do the rest

and now ive got a error 500 but systemctl status is showing me its clearly not likeing the lack of table/connecting to db . going to try install script with user, db and passwds known and see if it populates this time.

updating here in case it helps anyone else

+++ mysql -h localhost -Dcateye -uredacted
note i took out username but left the spacing how it was…this is what i mentioned earlier not sure how it parses/regex could probably be set not to care but i dont think ive ever seen switches with out a space like that in the past/highly suspicious of it.

maybe falsely … clipboard from ssh, paste as it was and im sitting at a logged in sql prompt …hmm
reading more of the output it tried to grab a db back up to restore… i wonder if that was empty as well?

Restoring DB from previously taken backup in /var/lib/bluecherry/bc_db_backup.ogwMFPbLCN.sql.gz

i purged bc in apt after cleaning out the maria source… did it again just now
sudo apt remove --purge bluecherry , the pinkish screen for package config was back and noting i should run apt-get /old syntax i thought was made to work the same anyway (possible the conditional in script isnt aware?) possibly it was file ownership… centos bad habits/ ubuntu sudo yourself to death, i might have run install from inside a root shell via sudo su -

i deleted the db back up and that dir … ran install again, no errors… and https://natedlocalip:7001 is now at a login prompt ! pretty sure i shot myself in the foot a few ways here at the start but maybe this helps someone else

back on nvidia now… i ended up hitting syslog through portal first

Failed to initialize VAAPI device /dev/dri/renderD128, VAAPI hardware acceleration is not available

it saw it on its own. im highly suspect of if the passthrough is working or not. damn nvidia card doesnt have a vga output and the only monitor near it is vga on the hosts ikvm/pretends to be graphics arm chip, there are issues ive seen in the past were if the vm with the card gets rebooted the magic smoke comes out of the pass through (virtually…or something like that) until underlying box is rebooted… probably something to do with the gfx rom. ill report back as i make progress