GeoVision ONVIF camera not reconized

I have been running the Blue cherry system on Linux since January and i am very happy with it. I finally got around to adding my second camera. It is a GeoVision GV- TBL4705 bullet. I was easily able to add my 1st Geovision (different model ) without much any problem. I have tried at least 20 different setups and nothing seams to work. I can log into the camera just fine but can’t get it to comeup in liveview through the bluecherry system. Is there something I’m not doing right ?

Does recording work at all?

Can you paste the RTSP paths you used, or take a screen shot in the Bluecherry Device settings for the TBL4705?

Hi, Curtis,

The Top of Driveway is my original camera, which works great.
The Garage driveway is my new camera that won’t connect. Note I tried to change the RTSP to 8554 after 554 didn’t work. I also tried many other camera models to no avail.

The port should be 554. Can you click on ‘ONVIF Probe & Autoconfigure’ and see if anything is returned?

Try setting the camera to H.264 instead of H.265

Last night our internet went down. First time since installing Starlink 8 months ago. I believe it was a major upgrade, since afterwards speeds were very fast. Anyway I got up last night around 3pm and reset the camera back to 554 then clicked “ONVIF Probe & Autoconfigure” . It did return a change. i tried that once before but the change didn’t appear to work. But this time I was working on my laptop and not directly on the server. I started the BlueCherry client up and both cameras work. I had been originally working off the server and as before Live View only works on the first camera. the new camera brings up the player screen but can’t get a connection. I really rely on it working, I have a HDMIi connection to my Livingroom TV so I can monitor the live feed during the day. Any ideas how to correct?

Note: I just realized only the liveview in BlueCherry Client works. The recordings are all blank.

See attached screen shot of autoconfigure.

Can you change the non working camera that returns black video to H.264? Can you try to disable audio if that doesn’t work?

I am not using audio, it is not enabled. I tried at H.264 same results. I went into the the folder that stores all my saves that you setup for me at: MNT/Store/ . I noticed there was an image and a video for each recording. The old camera plays fine from there. The new camera comes up with a player error, I tried to attached screenshot of error but it comes back with not able to at this time. So i have typed out the error:

The error is:
You have obsolete packages installed. Please update the following:
Libc-bin, Libc6, linsystemd0, libudev1, locales

Upgrade status
No upgrade log present

adm cdrom dip lpadmin lxd plugdev sambashare sudo

Error: [Errno 2] No such file or directory:‘/var/log/Xorg.0.log’

Update Update!!! After letting the system sit for awhile from changing the video to H.264 it now is working. in both the live and play back on the sever and client.

Thanks. I think your problems with H.265 will be fixed in RC9, which I can send to you if you are interested in testing. If you are interested let me know which Linux distribution you are using or if you are using the docker install method.

Is it difficult to upgrade to RC9 ? I ask because I have a lot on my platter right now and not a lot of time to devote to it. Would I also need to upgrade the client ? If you feel it would be worthwhile to proceed my Linux distribution is ubuntu 22.04.03 LTS. I am not using the docker method.

Thanks for all your help, greatly appreciated.

Sorry I tried to delete a post about a problem I had but resolved. didn’t see how to delete so I erased the post as an edit.

How did you resolve the problem you had? I went to reply and your message was gone :slight_smile:

I forgot to update the passwords for the cameras in the device settings to match the passwords I had changed in the cameras. I had to run out of town to pickup something and on my way I realized what I had forgotten to do. Sorry, I didn’t know you had already read the original post. I should have just updated it with the corrective action.

Should be easy:

sudo dpkg -i bluecherry_3.1.0-rc9_amd64.deb