Fresh install problem

I have a fresh new Linux install (Ubuntu server 22.04.04), first thing i’ve done is installing LAMP (Apache2, mysql 8.0.36, PHP 8.1.2). Nothing else is setup or changed,
I run the Docker installation with the command:
sudo bash -c "$(curl -fsSL"

No errors during install. At the end i could login to the :7001 address, changed admin password. Wanted to setup the storage locations (default path: /var/lib/bluecherry/recordings) but it says " Specified directory “/var/lib/bluecherry/recordings " exists, but is not writable See Note 2.”
Ok, the path was not created. i created, setup as follows:

sudo mkdir -p /var/lib/bluecherry/recordings
sudo chmod 770 /var/lib/bluecherry/recordings
sudo chown -R bluecherry:bluecherry /var/lib/bluecherry/recordings

The last command failed, because there was no user “bluecherry” (i dont knwo why, it should be…) I created the user, added to the group, and after that the chown command was completed successfully. However when i press the “Save changes” button, the error is still the same. " Specified directory “/var/lib/bluecherry/recordings " exists, but is not writable See Note 2.”

I had the same problem when i installed on a VM server a few days ago. Whats the problem, and what shpuld i do?

Ok i have the sollution. It installs the server version 3.1.0-rc9 which has a bug. After installation it was needed to refresh the version with those commands:

The commands has to be fired IN the bluecherry-docker folder (for me it was here: /home/mcll/bluecherry-docker). Go to that folder and run the following:

sudo docker compose stop
sudo docker compose down
sudo docker compose pull
sudo docker compose up -d

When running the pull comand it has to be download a few things If it does not, you have to repeat the four commands. After that the version is 3.1.0-rc10, which will accpet the recording folder, and set it up.

But interesting is, that the fodler in the config was setup to “/var/lib/bluecherry/recordings”, however the events were recorded in the docker folder!! By me the events are stored here: “/home/mcll/bluecherry-docker/recordings” and not in the folder set in the config…

So its a bug, i think.

And another problem: The events created by the server version 3.1.0-rc10 are not more shown in the client 2.2.9. :frowning: They are visible only in client version 3, but i don’t like it, as its not so stable as the 2.2.9 is. Crashes a lot, live cams are stopping, etc.