Ffmpeg CPU through the roof on new install

#1

Any idea why ffmpeg would be using 100% CPU usage on a new install. This is on Debian 9. I followed the official instructions and got it installed (even though there is no coherent instruction list. One page gives you a curl command, while another page buried in your site shows specific install instructions for Debian 9).

Top was showing two PIDs for www-data/ffmpeg that were both running flat out 100% CPU usage each. My four core machine was running a 1 minute load average of 7 with these two processes. I ended up killing them and removing Bluecherry from the machine until I can figure out the issue.

I had only added one camera at this point. An Axis M5014 PTZ. I found its model number in your dropdown list so I added it exactly as shown. I selected RTSP as the transport method and not MPEG.

I thought perhaps it was the camera causing the problems, but then I disabled it but ffmpeg kept doing its thing (whatever that was on a disabled one camera system).

#2

Strange. Did you have audio enabled? If you switched to constant recording instead of motion detection did the CPU load decrease?

Thanks

#3

I’ll have to try it again. I’ll reinstall in the next couple of days and see if it does the same thing.

#4

Ok, so enabling audio for the camera in the Bluecherry admin panel brings the server to a halt. Everything runs fine until I check the audio box. I have to either “kill -9” the two processes or reboot.

Server runs fine if I don’t enable audio in the admin panel when I add the camera. However, once you enable it, its game over.