Error playing back motion recorded video (Error loading this resource)

Server Version 2.8.8 running on Ubuntu 18.04 VM.

Running into this error when attempting to playback motion recorded video:

And when I attempt to download either the MP4 or MKV, I’m presented with a new browser tab and an HTTP 500 error

I’ve seen another post regarding this issue, yet it was solved by disabling audio in the camera settings. I do not have audio enabled and still facing this issue. Live view is working fine.

Appreciate any thoughts anyone has in this regard.

Are you running this in a docker or in a VM? Can you message me the ssh login details and I’ll talk a look at it?

Thanks Curtis. Let me dig more into this tomorrow and I can see about giving you SSH access. It’s inside a KVM VM with no exposed ports to the internet at the moment.

I need to check if perhaps it’s a storage issue as the path where the video is being saved is an NFS share mounted to a local file system. I believe I have the permissions set correctly (bluecherry user and group as the owner and I set the attributes at 777 temporarily to try and work around the problem). I saw some reference in the documentation to the onwer:group needing to be the Apache user (www-data), yet the application complained if the owner:group was not set to bluecherry:blueCherry.

Ultimately I’m going to spin up another VM and deploy the beta (or I might run it on physical hardware). So if I cannot work around this, I might give that a try as a potential resolution.

Thanks so much.

Yeah, it sounds like a permission problem for sure, you can check the apache error logs (/var/log/bluecherry-error.log) to see what errors are in there.

bluecherry user and group should own /var/lib/bluecherry/recordings and chmod 0700:

drwxrwx— 2 bluecherry bluecherry 4096 Jan 3 2020 recordings

Not seeing much in the logs with respect to errors. I confirmed the issue is with my NFS mount as using local storage resolves the issue. The user and group is correct for the path I’m using (bluecherry:bluecherry). And I’ve chmod 0700 the entire path. What’s interesting is the video files are being written without the execute bit being set. Thinking this might be the issue, I issued a chmod -R 777 to the entire path, which should resolve any issues with permissions. Unfortunately it doesn’t. I’m still digging into it. Need to be able to use network storage. I’ve run into issues like this in the past with NFS mounts and was able to resolve them, so I’m sure I’ll get it figured out. Solving this issue and I’m sold on Bluecherry. I cannot believe how much better the UI is when compared to some of the other Linux based solutions that people are using (i.e. Zoneminder, Shinobi, and MotionEye).

Can you paste the output if your NFS mount in fstab and the exports from the NFS server?

NFS permissions are always a pain to configure.

showmount -e NFSserver

ll /path/to/nfsmount

mount |grep -i nfs

I’m able to get NFS working from a FreeNAS server using a NFS export:

root@bc-stable:~# umount /media/nfstest ; mount /media/nfstest ; chown -R bluecherry.bluecherry -R /media/nfstest/
root@bc-stable:~# service bluecherry restart
root@bc-stable:~# cd /media/nfstest
root@bc-stable:/media/nfstest# ls
root@bc-stable:/media/nfstest# ls -ltrc
total 0
root@bc-stable:/media/nfstest# service bluecherry restart
root@bc-stable:/media/nfstest# ls
root@bc-stable:/media/nfstest# cd 2020
root@bc-stable:/media/nfstest/2020# ls
root@bc-stable:/media/nfstest/2020# ls -ltrc
total 1
drwxrwxrwx 3 bluecherry bluecherry 3 Sep 3 18:56 09
root@bc-stable:/media/nfstest/2020# cd 09
root@bc-stable:/media/nfstest/2020/09# ls
root@bc-stable:/media/nfstest/2020/09# cd 03
root@bc-stable:/media/nfstest/2020/09/03# ls
000001 000004 000005 000006 000008
root@bc-stable:/media/nfstest/2020/09/03# ls -ltrc
total 3
drwxrwxrwx 2 bluecherry bluecherry 4 Sep 3 18:56 000001
drwxrwxrwx 2 bluecherry bluecherry 3 Sep 3 18:56 000005
drwxrwxrwx 2 bluecherry bluecherry 3 Sep 3 18:56 000006
drwxrwxrwx 2 bluecherry bluecherry 3 Sep 3 18:56 000004
drwxrwxrwx 2 bluecherry bluecherry 4 Sep 3 18:56 000008

I’m using a Netgear ReadyNAS. Was thinking maybe it’s a user issue on the NAS, so I’m experimenting with creating the same user and group on the NAS including matching the user and group UID. If this doesn’t work, I’ll just give the VM a second virtual disk for video storage. Thanks so much Curtis.

showmount -e
Export list for

Here is what I had in my fstab: /home/bluecherry/ nfs defaults 0 0

I’ve pretty much solved it by giving the VM another virtual harddisk for video storage. Ultimately, I’ll probably setup a backup job or rsync to copy the video off to my backup server on some sort of a regular basis to have a second copy of the stored video. This will work for me for the time being. I’ll revisit the NFS issues when I’m ready to roll out the beta.

Just to share for the benefit of anyone else running up against this, I gave up on NFS and went the route of using CIFS/SMB shares from my NAS mounted in the BlueCherry v3 beta VM. This solved the permissions issues and my recorded video is now saved on the SMB network file share, allowing me to access it in various ways, as well as routinely backup the video for archival purposes. Not that I couldn’t have achieved this in other ways, but I really wanted the video stored natively on the NAS appliance.