Client docker container in linux Mint 20

I upgraded to Mint 20 but I see that the client is not yet compatible.
I built a container to try to run it in an Ubuntu 16 environment. It will run the client and stream the live feed from the camera but it will not display recorded clips.

dockerfile
FROM ubuntu:16.04
COPY bluecherry-client_2.2.6-1_amd64.deb /
RUN apt-get update && apt-get install -y sudo less
RUN dpkg -i bluecherry-client_2.2.6-1_amd64.deb; exit 0
RUN apt-get -yf install
CMD /usr/bin/bluecherry-client

You will need to allow x access locally with:

xhost +local:root

run with:

sudo docker run -ti --rm \
   -e DISPLAY=unix$DISPLAY \
   -v $HOME/.Xauthority:$HOME/.Xauthority \
   --network=host \
   bluecherry-client

STDOUT from container:

VAAPI - using X11 display “unix:0”
trying to create VAAPI device context " unix:0 "
libva info: VA-API version 0.39.0
libva info: va_getDriverName() returns -1
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
[AVHWDeviceContext @ 0x186ca00] Failed to initialise VAAPI connection: -1 (unknown libva error).
Failed to create VAAPI device context
static bool QDeclarativeMetaType::isModule(const QByteArray&, int, int) Qt 4.7 import detected; please note that Qt 4.7 is directly reusable as QtQuick 1.x with no code changes. Continuing, but startup time will be slower.
void UpdateChecker::versionInfoReceived() Latest version info: “2.2.6”

If anyone is able to improve on that it would be a useful temp solution
thanks

I have been able to resolve the playback issue by changing the “MPlayer video output driver” to “gl”
in the client Options menu

woop!

Unable to find image ‘bluecherry-client:latest’ locally
docker: Error response from daemon: pull access denied for bluecherry-client, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied.
See ‘docker run --help’.

Tried to pull the container in Ubuntu. Ran into the above.

Thanks

You can use this docker from GitHub - https://github.com/staal0/BluecherryClient-docker

1 Like

Worked through everything in the readme file. Have all the files and the .deb in place. Running into this:

:~/bluecherry$ sh run.sh
docker: unknown server OS: .
See ‘docker run --help’.

Unclear if this is a Docker/Environment issue or something in the script. I’m attempting to run the container on a Ubuntu 20.04 host with KDE as the DE and the Ubuntu 5.4 lowlatency kernel (5.4.0-45-lowlatency #49-Ubuntu SMP PREEMPT Wed Aug 26 15:06:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux)

Thanks so much Curtis for your quick responses. At this point, I’m sold on Bluecherry. Just need to spend some more time evaluating it.

I uploaded a docker image for the Bluecherry client based on Ubuntu 18.04 until a 20.04 client is released: